E Zigarette unter Linux updaten / Logos hochladen

Wie jedes elektrische Gerät wollen auch E-Zigaretten Updates bekommen. Dabei werden Bugfixes eingespielt und neue Features. Die Hersteller bieten natürlich keine Lösung für Linux an. In diesem Beitrag erkläre ich Dir wie Du Updates unter Linux einspielen kannst. Getestet habe ich das mit einer eVic VTwo mini und dem iStick Pico. Unterstützt werden wohl folgende Modelle:

  • eVic VTwo
  • Evic VTC Mini
  • Cuboid Mini
  • Cuboid
  • eGrip II
  • eVic AIO
  • eVic VTwo mini
  • eVic Basic
  • iStick TC100W
  • ASTER
  • iStick Pico
  • iStick Pico Mega
  • iPower
  • Presa TC75W
  • Vaporflask Classic
  • Vaporflask Lite
  • Vaporflask Stout
  • Reuleaux RX200
  • CENTURION
  • Reuleaux RX2/3
  • Reuleaux RX200S

Der Vorgang spielt sich in der Shell ab. Falls Du damit noch nicht so sicher bist solltest Du unbedingt bei den Ubuntuusers vorbeischauen. Für das Updaten wird python-evic von Ban3 verwendet.

Benötigte Pakete installieren

 

sudo apt-get install git python-dev python-setuptools cython libhidapi-dev libusb-1.0-0-dev libudev-dev python-pip

Python Evic installieren

Das Repository clonen

git clone git://github.com/Ban3/python-evic.git && cd python-evic

Berechtigungen für udev setzen

sudo cp udev/99-nuvoton-hid.rules /etc/udev/rules.d/ && sudo service udev restart

Python-Evic installieren

sudo python setup.py install

Updates einspielen

Zuerst mußt Du dir das Update beim Hersteller downloaden.

Updates bei Joyetech

Updates bei Eleaf

Nun das Gerät per USB an den Rechner anschließen und in der Konsole in das Verzeichnis wechseln und evic-usb mit dem Namen des .bin Files ausführen

evic-usb upload eVic_VTwo_mini_V5.04.bin

Eigene Logos hochladen

Dafür benötigst du ein Bitmap (bmp) in den Abmessungen 64x40px.

evic-usb upload-logo Logo.bmp

Wenn dieser Beitrag hilfreich für Dich war kannst Du mich unterstützen, indem Du auf diesen Link klickst um bei Amazon einzukaufen.

9 thoughts on “E Zigarette unter Linux updaten / Logos hochladen

    1. Die Firmware dient primär der Steuerung. Ich kann damit z.B. angeben wie heiß der Draht maximal werden darf während des Feuerns.

  1. Hallo,
    ich habe deine Anleitung mit meinem Cuboid ausprobiert, es scheint aber leider nicht zu klappen:

    fin-fin@LordVader:~/Downloads/UpdateFirmware/python-evic$ evic-usb upload Cuboid_V5.04.bin
    Traceback (most recent call last):
    File „/usr/local/bin/evic-usb“, line 9, in
    load_entry_point(‚evic==0.1‘, ‚console_scripts‘, ‚evic-usb‘)()
    File „/usr/lib/python2.7/dist-packages/pkg_resources/__init__.py“, line 542, in load_entry_point
    return get_distribution(dist).load_entry_point(group, name)
    File „/usr/lib/python2.7/dist-packages/pkg_resources/__init__.py“, line 2569, in load_entry_point
    return ep.load()
    File „/usr/lib/python2.7/dist-packages/pkg_resources/__init__.py“, line 2228, in load
    self.require(*args, **kwargs)
    File „/usr/lib/python2.7/dist-packages/pkg_resources/__init__.py“, line 2245, in require
    items = working_set.resolve(reqs, env, installer)
    File „/usr/lib/python2.7/dist-packages/pkg_resources/__init__.py“, line 829, in resolve
    raise DistributionNotFound(req, requirers)
    pkg_resources.DistributionNotFound: The ‚hidapi>=0.7.99‘ distribution was not found and is required by the application

    Kannst du mir da irgendwie weiterhelfen?

    Dankeschön!
    Daniel

    1. Hi Daniel,

      lies Dir die Fehlermeldung durch

      pkg_resources.DistributionNotFound: The ‚hidapi>=0.7.99‘ distribution was not found and is required by the application

      Hast Du die hidapi installiert?

      sudo apt-get install git python-dev python-setuptools cython libhidapi-dev libusb-1.0-0-dev libudev-dev python-pip

  2. Hallo,
    Danke für deine Antwort!
    Ja, hidapi ist installiert:

    »git« ist bereits die neuste Version (1:2.7.4-0ubuntu1).
    »libusb-1.0-0-dev« ist bereits die neuste Version (2:1.0.20-1).
    »python-dev« ist bereits die neuste Version (2.7.11-1).
    »python-setuptools« ist bereits die neuste Version (20.7.0-1).
    »cython« ist bereits die neuste Version (0.23.4-0ubuntu5).
    »libhidapi-dev« ist bereits die neuste Version (0.8.0~rc1+git20140818.d17db57+dfsg-1).
    »libudev-dev« ist bereits die neuste Version (229-4ubuntu16).
    »python-pip« ist bereits die neuste Version (8.1.1-2ubuntu0.4).
    0 aktualisiert, 0 neu installiert, 0 zu entfernen und 4 nicht aktualisiert.

    Allerdings die Version 0.8.0, oder?
    Kann die zu neu sein? Weil die Fehlermeldung verlangt ja 0.7.99?

  3. Hallo Michael,

    deine Anleitung ist super, jedoch erhalte ich folgende meldung, beim versuch die benötigten Pakete zu instalieren.

    # sudo apt-get install git python-dev python-setuptools cython libhidapi-dev libusb-1.0-0-dev libudev-dev python-pip
    Paketlisten werden gelesen… Fertig
    Abhängigkeitsbaum wird aufgebaut.
    Statusinformationen werden eingelesen…. Fertig
    Einige Pakete konnten nicht installiert werden. Das kann bedeuten, dass
    Sie eine unmögliche Situation angefordert haben oder, wenn Sie die
    Unstable-Distribution verwenden, dass einige erforderliche Pakete noch
    nicht erstellt wurden oder Incoming noch nicht verlassen haben.
    Die folgenden Informationen helfen Ihnen vielleicht, die Situation zu lösen:

    Die folgenden Pakete haben unerfüllte Abhängigkeiten:
    udev : Beschädigt: systemd (< 232-11) aber 231-4 soll installiert werden
    E: Fehler: Unterbrechungen durch pkgProblemResolver::Resolve hervorgerufen; dies könnte durch zurückgehaltene Pakete verursacht worden sein.

Schreibe einen Kommentar

Deine E-Mail-Adresse wird nicht veröffentlicht.